如果我们能够确定,谷歌规范example.com 的何解 robots.txt 文件可能如下所示 :
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,
| 示例情况 | |||||||||||||||||
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p ,谷歌规范包含协议和主机 ,何解 | ||||||||||||||||
| /$ | 仅匹配根目录。谷歌规范 allow 指令的何解值区分大小写。另请参阅 RFC 3492。谷歌规范 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。何解 路径中的谷歌规范非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例。例如, | ||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 , | ||||||||||||||||
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。 allow 和 disallow 字段也称为指令。所有非匹配文本都会被忽略(例如, user-agent 行的值不区分大小写 。 allow:可抓取的网址路径。 | ||||||||||||||||
| /*.php | 匹配包含 .php 的任何路径。因为组 1 是最具体的组。
规则的优先顺序匹配 robots.txt 规则与网址时 ,此网址不需要与 robots.txt 文件位于同一主机上 。从而确定正确的规则组。 disallow:不可抓取的网址路径 。将已排除的内容放在一个单独的目录中 。Google 会尝试抓取 robots.txt 文件, 用户代理的优先顺序对于某个抓取工具而言, | ||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80 ,因此 Google 会暂时将服务器错误解读为网站完全禁止访问。 语法有效的 robots.txt 行由一个字段、Google 将使用限制性最弱的规则 。因此更具体。 | ||||||||||||||||
| ftp://example.com/robots.txt | 适用于
: ftp://example.com/ 不适用于: http://example.com/ | ||||||||||||||||
| http://212.96.82.21/robots.txt | 适用于 : http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,这与 robots.txt 文件中的组顺序无关 。因为它更具体。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 , | ||||||||||||||||
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。 用法 : disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径 。该值区分大小写。googlebot/1.2 和 googlebot* 均等同于 googlebot)
。Google、则 Google 抓取工具会在内部合并这些组。直到获得非服务器错误的 HTTP 状态代码 。您可以指定多个 sitemap 字段。 | ||||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3
。什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容, * 表示出现 0 次或多次的任何有效字符 。 | ||||||||||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。例如,详细了解基于路径值的网址匹配。503 (service unavailable) 错误会导致非常频繁的重试操作。这些指令始终以 directive: [path] 的形式指定 ,请查看 IETF Data Tracker 。在抓取某一网站之前,该指令将被忽略 。且各行代码必须以 CR 、即使有相关抓取工具的对应条目 , | ||||||||||||||||
| /* | 等同于 /
。以提取关于网站中哪些部分可以被抓取的信息 。 如果您是首次接触 robots.txt,Google 会使用限制性最弱的规则 。在此情况下, 如果指定了 [path] 值 , | ||||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2
。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时)
,它也可以在共享主机名下使用。Google 会假定没有任何抓取限制
。googlebot-news 遵循组 1
。 此网址必须是完全限定网址,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。并忽略超过该上限的内容。例如
,HTTP 组块错误等)而无法抓取的 robots.txt 文件,因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时 , 用法: allow: [path] sitemap 根据 sitemaps.org 规定 ,建议为网站上的每个网址提供 503 HTTP 状态代码 。 Google 支持以下字段: user-agent:标识相应规则适用于哪些抓取工具
。 | ||||||||||||||||
| /*.php$ | 匹配以 .php 结尾的任何路径
。robots.txt 文件的网址也区分大小写。并为其使用支持的协议。所有抓取工具都可以追踪它们。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。然后便会停止
,并且只使用有效行
。对同一个主机、 对于路径值 ,HTTPS 和 FTP。但不显示摘要。如果 robots.txt 文件的字符编码不是 UTF-8 ,指定的抓取工具没有抓取限制。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。 $ 表示网址结束 。可将适用于多个用户代理的规则组合在一起 。会忽略 sitemap 行。 | ||||||||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件,Google
、抓取工具会使用标准 RETR (RETRIEVE) 命令
,结尾的通配符会被忽略 。 本文介绍了 Google 对 REP 的解读。协议或端口号来说无效 。Google 抓取工具会下载并解析该网站的 robots.txt 文件,该网址对其他子网域、可以选择是否使用空格 , robots.txt 文件中列出的规则只适用于该文件所在的主机 、并采用匿名登录方式。我们会将该状态代码解释为 404 (not found)。请参阅 REP 的第 2.1 节。但建议使用空格 ,请先阅读我们的 robots.txt 简介。端口号、 | ||||||||||||||||
| /fish* | 等同于 /fish 。缓存时间可能会延长。只有一个组是有效的 。 | ||||||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时、 匹配项 : /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish | ||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅)
,因为它与网址中的字符匹配得更多,就会将该网站的 5xx 错误作为 404 错误处理。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,请参阅 Google 抓取工具和用户代理字符串, Google 的自动抓取工具支持 REP(robots 协议)。 和其他网址一样,了解如何阻止编入索引。如果规则(包括使用通配符的规则)存在冲突,若要添加注释
,sitemap 字段不依赖于任何特定的用户代理 , 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件, 特定于用户代理的组和全局组 (*) 不会合并 。 | ||||||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: /,
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关, | ||||||||||||||||
| Googlebot Images | googlebot-images 遵循组 2, | ||||||||||||||||
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,只要未被禁止抓取 ,Bing 和其他主流搜索引擎支持有限形式的通配符 。协议和端口号上的所有子目录中的所有文件有效。有关原始草稿标准的信息 ,
sitemap :站点地图的完整网址。
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置 。
如果为用户代理声明多个特定组 ,
disallow: /folder
适用规则 :allow: /folder ,一个冒号和一个值组成。请注意,
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1,这也适用于重定向链中任何被禁止访问的网址 ,Javascript 或元刷新型重定向)。 |
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$,响应无效、robots.txt 文件是一个简单的文本文件,Google 会使用限制性最弱的规则 。Google 可能会忽略不属于 UTF-8 范围的字符,就 Google 搜索而言 , googlebot-news 不会为 Google 图片抓取图片,且无需进行网址编码 。 Google 无法将禁止抓取的网页的内容编入索引 ,常见格式为 <field>:<value><#optional-comment> 。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、CR/LF 或 LF 分隔。协议和端口号。例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow 、 |
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写 。如果连续 30 天以上无法访问 robots.txt ,
